Delayed Data Ingestion

Incident Report for ActivTrak

Resolved

Our engineering team implemented a fix last night and confirms that delayed data collection is now resolved. No data loss is occurring due to these delays.
Posted Jun 11, 2026 - 15:20 UTC

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 21:29 UTC

Investigating

Some users may be experiencing delays in agent data collection. Our engineering team is looking into the issue. No data loss is occurring due to these delays.
Posted Jun 10, 2026 - 21:28 UTC
This incident affected: Data Ingestion.